MagicalRecord 2.3 is a point release update, so we’ve done our best to make sure it’s still compatible with the same methods you were using under earlier releases. There are, however, a few places where things needed to change to support upcoming features in MagicalRecord 3.0, or to fix bugs that couldn’t be fixed in other ways.

With a couple of noted exceptions, your app should still build and run under MagicalRecord 2.3 if you were running version 2.2.

Logging

We’ve replaced our logging with code that’s configurable at runtime, rather than requiring project configuration changes. There are more details in our Logging Guide.

Deprecated methods

For the most part, you should just be able to build your app with MagicalRecord 2.3 and Xcode will point out any places you need update your methods to non-deprecated alternatives (it’ll even tell you what to replace it with!).